Diferenças

Aqui você vê as diferenças entre duas revisões dessa página.

Link para esta página de comparações

firefox_52-instalacao [2018/07/18 16:42] (atual)
fred criada
Linha 1: Linha 1:
 +====== Atualização do Firefox na Libertas 6 - Procedimentos de instalação ======
  
 +Após a execução das tarefas descritas [[firefox_52|nesse procedimento]],​ o arquivo de atualizações do //Firefox// estará disponível no //home// do usuário local (''/​var/​users/​local''​). A máquina deve então ser acessada como //root// e devem-se seguir os procedimentos abaixo:
 +
 +  - A partir do //home// do //root//, descompactar o arquivo com o comando:<​code>​
 + tar xjvf /​var/​users/​local/​atualiza_firefox_52.tar.bz2</​code>​
 +  - Entrar no diretório criado:<​code>​
 +cd atualiza_firefox_52</​code>​
 +  - Por precaução,​ matar o processo do //​iceweasel//​ (não necessariamente ele estará ativo):<​code>​
 +killall iceweasel</​code>​
 +  - Desinstalar os pacotes do //​Iceweasel//:<​code>​
 +aptitude purge iceweasel iceweasel-l10n-pt-br</​code>​
 +  - Instala os novos pacotes do //Firefox// e suas dependências:<​code>​
 +dpkg -i *</​code>​
 +
 +===== Possíveis problemas =====
 +
 +Existem dois problemas já identificados no processo de atualização. Podem existir outros que ainda não foram identificados e devem ser tratados após investigar sua causa. Os erros conhecidos estão descritos abaixo.
 +
 +=== O arquivo de atualização não está no diretório correto ===
 +
 +Ao tentar executar o procedimento **1** ocorre um erro de arquivo não encontrado. Nesse caso pode-se baixar o arquivo de instalação diretamente da fonte:
 +
 +  wget "​http://​libertas.pbh.gov.br/​dld_arqs/​atualiza_firefox_52.tar.bz2"​
 +
 +A partir daí descompacta-se esse arquivo e seguem-se os procedimentos a partir do **2**.
 +
 +Caso a rede da escola seja muito lenta, é preferível baixar o arquivo em um computador e, a partir dele, copiar para as outras máquinas.
 +
 +=== O computador está desatualizado ===
 +
 +Ao tentar executar o procedimento **5**, ocorre um erro indicando que o pacote //​multiarch-support//​ não está instalado. Nesse caso, a tentativa de instalação é interrompida e apresenta, ao final, os seguintes erros:
 +
 +<​code>​
 +Erros foram encontrados durante o processamento de:
 + ​libatk1.0-0_2.4.0-2_i386.deb
 + ​libcairo-gobject2_1.12.2-3+deb7u1_i386.deb
 + ​libcolord1_0.1.21-1_i386.deb
 + ​libgtk-3-0_3.4.2-7+deb7u1_i386.deb
 + ​liblcms2-2_2.2+git20110628-2.2+deb7u2_i386.deb
 + ​libpango1.0-0_1.30.0-1_i386.deb
 + ​firefox-esr
 + ​firefox-esr-l10n-pt-br
 + ​libgtk-3-common
 +</​code>​
 +
 +Nesse caso é necessário atualizar o computador para a última versão da //​Libertas//​ 6. Para isso, o arquivo ''/​etc/​apt/​sources.list''​ deve ser editado e o seu conteúdo deve ser alterado para:
 +
 +  deb http://​repos.smed.pbh/​libertas-squeeze libertas main contrib non-free
 +
 +Após a alteração,​ atualiza-se o banco de dados com o comando:
 +
 +  aptitude update
 +
 +e atualiza-se a máquina com o comando:
 +
 +  aptitude dist-upgrade
 +
 +Durante a atualização devem-se confirmar todas as opções, escolhendo "​Sim"​ ou "​Y"​. Ao final da atualização é necessário instalar dois novos pacotes, com o comando abaixo:
 +
 +  aptitude install libevent-2.0-5 libhunspell-1.3-0
 +
 +Feito isso, o procedimento **5** pode ser novamente executado para atualização do navegador.
 +
 +Caso a rede da escola seja muito lenta, esse procedimento será bastante demorado. Nesses casos, evite atualizar mais de uma máquina ao mesmo tempo, pois a lentidão será ainda maior.